In webkit-gtk-2.3.3 (compared to 2.2.3), CheckSystemAndBasicDependencies.m4 was updated to error out if anything other than libstdc++ >= 4.8.1 is used. This causes configure to error out when using libc++, but libc++ should work fine.
--- Source/autotools/CheckSystemAndBasicDependencies.m4.orig 2014-01-03 08:55:20.000000000 -0800
+++ Source/autotools/CheckSystemAndBasicDependencies.m4 2014-01-03 08:57:19.000000000 -0800
@@ -123,14 +123,6 @@ elif test "$cxx_compiler" = "clang++"; t
-#if defined(__GLIBCXX__) && __GLIBCXX__ >= 20130531
-bool libstdcxxTest = std::is_trivially_destructible<bool>::value;
-#error libstdc++ >= 4.8.1 is required
-])], , [AC_MSG_ERROR([libstdc++ >= 4.8.1 is required as the standard library used with the Clang compiler.])])
Note that we're using the above as a workaround. I was just providing it to indicate the source of the problem. It's obviously not suited for integration as you likely just want to error out if libstdc++ older than 4.8.1 is used.
I suggest you change that to:
#if defined(__GLIBCXX__) && __GLIBCXX__ < 20130531
#error libstdc++ < 4.8.1 is not supported
Related to #126325
The solution to this bug depends on bug #126325.
Created attachment 220421 [details]
Comment on attachment 220421 [details]
Clearing flags on attachment: 220421
Committed r161359: <http://trac.webkit.org/changeset/161359>
All reviewed patches have been landed. Closing bug.