Bug 126261 - [WK2][CoordinatedGraphics] Adding callback to let WebView know that WebPageProxy has changed its pageScaleFactor
Summary: [WK2][CoordinatedGraphics] Adding callback to let WebView know that WebPagePr...
Status: RESOLVED DUPLICATE of bug 127090
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Thiago de Barros Lacerda
URL:
Keywords:
Depends on:
Blocks: 126960
  Show dependency treegraph
 
Reported: 2013-12-27 06:43 PST by Thiago de Barros Lacerda
Modified: 2014-01-20 15:05 PST (History)
11 users (show)

See Also:


Attachments
Patch (6.98 KB, patch)
2013-12-27 06:51 PST, Thiago de Barros Lacerda
no flags Details | Formatted Diff | Diff
Patch (10.95 KB, patch)
2013-12-27 09:52 PST, Thiago de Barros Lacerda
no flags Details | Formatted Diff | Diff
Patch (11.22 KB, patch)
2014-01-02 16:01 PST, Thiago de Barros Lacerda
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago de Barros Lacerda 2013-12-27 06:43:54 PST
After r161087, the scale factor is being set directly in WebPageProxy, avoiding information duplication of the scale factor.
However, it takes a while to the scale factor gets applied in WebProcess and get back to UIProcess (WebPageProxy) due do IPC.
So, during this interval, if the user queries the contentScaleFactor to the WebView he will get the old scale factor.
This callback is useful to let the user know when it can rely on the contentScaleFactor. It is also important for API tests that might use contentScaleFactor
Comment 1 Thiago de Barros Lacerda 2013-12-27 06:51:31 PST
Created attachment 220058 [details]
Patch
Comment 2 Thiago de Barros Lacerda 2013-12-27 09:52:06 PST
Created attachment 220063 [details]
Patch
Comment 3 Thiago de Barros Lacerda 2013-12-27 09:54:02 PST
(In reply to comment #2)
> Created an attachment (id=220063) [details]
> Patch

Forgot to fix the test
Comment 4 Thiago de Barros Lacerda 2014-01-02 16:01:27 PST
Created attachment 220263 [details]
Patch
Comment 5 Thiago de Barros Lacerda 2014-01-16 02:19:35 PST

*** This bug has been marked as a duplicate of bug 127090 ***