Bug 126260 - [CSS Regions] ruby base is not rendered on the second region when using css regions
Summary: [CSS Regions] ruby base is not rendered on the second region when using css r...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.9
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 57312
  Show dependency treegraph
 
Reported: 2013-12-27 03:42 PST by ken_his
Modified: 2014-05-26 08:03 PDT (History)
2 users (show)

See Also:


Attachments
a simplified reproducing content (633 bytes, application/xhtml+xml)
2013-12-27 03:42 PST, ken_his
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description ken_his 2013-12-27 03:42:33 PST
Created attachment 220057 [details]
a simplified reproducing content

With contents using css region, ruby base is not rendered on the second region.

The attached content is a simple content to reproduce this issue.
It has "A" as a base of ruby "a" on the first region 
and "B" as a base of ruby "b" on the second region.
"B" is not rendered with this content.

It's reproducible with r161096 built from source code.
(and reproducible with nightly build r161093 also)


RenderFlowThread::objectShouldPaintInFlowRegion() seems to prevent "B" from being rendered with region check by regionInRange(). 
(I've confirmed that "B" is rendered with temporary modification that makes regionInRange() return true.)
This is because the mapped range of regions of "B" is different from the given region of objectShouldPaintInFlowRegion's argument.
Comment 1 Mihnea Ovidenie 2014-04-06 23:17:47 PDT
Would you mind testing it again with the latest nightly, it works for me.
Comment 2 Mihnea Ovidenie 2014-05-26 08:03:54 PDT
Tested with 168728.