Bug 12619 - Non-abbreviated XPaths don't work
Summary: Non-abbreviated XPaths don't work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: XML (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks: 12584
  Show dependency treegraph
 
Reported: 2007-02-05 13:05 PST by Alexey Proskuryakov
Modified: 2007-02-15 01:06 PST (History)
0 users

See Also:


Attachments
test case (627 bytes, text/html)
2007-02-05 13:06 PST, Alexey Proskuryakov
no flags Details
proposed fix (3.89 KB, patch)
2007-02-05 21:48 PST, Alexey Proskuryakov
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2007-02-05 13:05:15 PST
It seems to be an issue in the parser that garbage is sent to XPath::Step ctor instead of correct Axis ids.
Comment 1 Alexey Proskuryakov 2007-02-05 13:06:07 PST
Created attachment 12941 [details]
test case
Comment 2 Alexey Proskuryakov 2007-02-05 13:40:00 PST
I have a fix for this issue (which is caused by a missing break in a switch statement in Parser::lex()), but my test case still doesn't work correctly. WebKit and Firefox/Opera seem to have different ideas about what a root node is (in Firefox, it's the document element, while in WebKit, it's the Document itself).

Going to investigate this further.
Comment 3 Alexey Proskuryakov 2007-02-05 21:48:39 PST
Created attachment 12960 [details]
proposed fix
Comment 4 Geoffrey Garen 2007-02-05 21:50:57 PST
Comment on attachment 12960 [details]
proposed fix

r=me
Comment 5 Alexey Proskuryakov 2007-02-05 21:53:19 PST
Committed revision 19425.