Bug 126048 - Subpixel layout: Content gets pushed off by one pixel on Amazon.com
Summary: Subpixel layout: Content gets pushed off by one pixel on Amazon.com
Status: RESOLVED DUPLICATE of bug 125829
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: zalan
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-12-19 21:18 PST by zalan
Modified: 2013-12-27 17:56 PST (History)
4 users (show)

See Also:


Attachments
test case (314 bytes, text/html)
2013-12-19 21:18 PST, zalan
no flags Details
screenshot(amazon) (251.23 KB, image/gif)
2013-12-19 21:23 PST, zalan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description zalan 2013-12-19 21:18:44 PST
Created attachment 219726 [details]
test case

The following content produces an off-by-one pixel issue when subpixel is enabled.

<html>
<head>
<style type="text/css">
  div {
    display: inline-block;
  }

  span {
    display: inline-block;
    margin: .385em;
  }

  body {
    font-size: 13px;
    font-family: Arial,sans-serif;
  }

  </style>
</head>
<body>
<div>
  <span></span><span></span>foo
</div>
<div>foobar</div>
</body>
</html>
Comment 1 zalan 2013-12-19 21:21:01 PST
<rdar://problem/15706040>
Comment 2 zalan 2013-12-19 21:23:04 PST
Created attachment 219727 [details]
screenshot(amazon)

anim gif to demonstrate the off-by-one pixel issue on amazon.com
Comment 3 zalan 2013-12-27 17:55:52 PST
This is the combination of bug 125911 and bug 125829
Comment 4 zalan 2013-12-27 17:56:21 PST

*** This bug has been marked as a duplicate of bug 125829 ***