Bug 12604 - REGRESSION: After closing the "Would you like to save password" sheet, the form fails to submit automatically at http://www.mac.com/WebObjects/HomePage.woa
Summary: REGRESSION: After closing the "Would you like to save password" sheet, the fo...
Status: RESOLVED DUPLICATE of bug 12690
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-02-04 12:42 PST by Maciej Stachowiak
Modified: 2007-03-02 00:28 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2007-02-04 12:42:20 PST
12/7/06 7:34 PM Chris Petersen:
* SUMMARY
With TOT (tiger) or Leopard9A321+ Safari-521.31.tar.gz, form fails to submit after closing the "Would you like to save password"  sheet at http://www.mac.com/WebObjects/HomePage.woa

This works fine on stock Leopard9A321. 

* STEPS TO REPRODUCE
1. With TOT (tiger) or Leopard9A321+ Safari-521.31.tar.gz, enable "Users names and password" in Auto Fill - Safari Preferences
2. Go to http://www.mac.com/WebObjects/HomePage.woa
3. Fill in Member name /Password fields
4. With the caret still in the password field, press the return key
5. The "Would you like to save password"  sheet appears. Click Yes to close the sheet.
6. Notice that after the sheet closes, the form on the page fails to submit ( to log you in)


* RESULTS
After the "Would you like to save password"  sheet closes , the form submission should occur but doesn't. The workaround is click the "login" button manually after the sheet has closed.

* REGRESSION
Yes, this works on stock Leopard9A321.

12/11/06 2:12 PM Stephanie Lewis:
Safari BRB Reviewed
Comment 1 Maciej Stachowiak 2007-02-04 12:43:24 PST
<rdar://problem/4871752>
Comment 2 Antti Koivisto 2007-03-02 00:28:25 PST
This was broken by r18011

*** This bug has been marked as a duplicate of 12690 ***