Bug 126002 - [GTK] Some unit tests using web extensions fail when run alone
Summary: [GTK] Some unit tests using web extensions fail when run alone
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 126006
  Show dependency treegraph
 
Reported: 2013-12-19 11:42 PST by Carlos Garcia Campos
Modified: 2013-12-20 04:08 PST (History)
3 users (show)

See Also:


Attachments
Patch (7.17 KB, patch)
2013-12-19 11:48 PST, Carlos Garcia Campos
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2013-12-19 11:42:17 PST
For example /webkit2/WebKitWebExtension/document-loaded-signal. The problem is that the page is created before the dbus connection has been established, and we are connecting to web-page-created signal once we have a valid dbus connection. We should connect to the signal before connecting to dbus and queue any request to emit a dbus signal until the connection is set. This also fixes the WebExtensions tests when using the network process because a new web process is launched for every test case.
Comment 1 Carlos Garcia Campos 2013-12-19 11:48:24 PST
Created attachment 219668 [details]
Patch
Comment 2 WebKit Commit Bot 2013-12-19 11:49:41 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Gustavo Noronha (kov) 2013-12-20 03:40:08 PST
Comment on attachment 219668 [details]
Patch

Quite clean. You could drop the type from the constructor and infer it based on which constructor gets selected (no URL => document loaded, URL => uri changed), but I think I prefer the explicit one, it's more future proof too.
Comment 4 Carlos Garcia Campos 2013-12-20 04:01:21 PST
(In reply to comment #3)
> (From update of attachment 219668 [details])
> Quite clean. You could drop the type from the constructor and infer it based on which constructor gets selected (no URL => document loaded, URL => uri changed), but I think I prefer the explicit one, it's more future proof too.

Thanks for the review.
Comment 5 Carlos Garcia Campos 2013-12-20 04:08:35 PST
Committed r160904: <http://trac.webkit.org/changeset/160904>