Bug 125909 - Web Inspector: handle scroll to zoom in TimelineOverview
Summary: Web Inspector: handle scroll to zoom in TimelineOverview
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Timothy Hatcher
URL:
Keywords: InRadar
: 14378 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-17 20:06 PST by Timothy Hatcher
Modified: 2014-01-20 19:02 PST (History)
5 users (show)

See Also:


Attachments
Patch (3.25 KB, patch)
2013-12-17 20:13 PST, Timothy Hatcher
no flags Details | Formatted Diff | Diff
Patch (3.80 KB, patch)
2013-12-18 10:33 PST, Timothy Hatcher
joepeck: review+
timothy: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timothy Hatcher 2013-12-17 20:06:57 PST
Support scroll up and down to zoom TimelineOverview.
Comment 1 Timothy Hatcher 2013-12-17 20:13:17 PST
Created attachment 219499 [details]
Patch
Comment 2 Timothy Hatcher 2013-12-18 10:33:06 PST
Created attachment 219546 [details]
Patch
Comment 3 Joseph Pecoraro 2013-12-18 10:46:45 PST
Comment on attachment 219546 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=219546&action=review

r=me

> Source/WebInspectorUI/UserInterface/TimelineOverview.js:169
> +        var deviceDirection = event.webkitDirectionInvertedFromDevice ? -1 : 1;

Does this match Instruments / OS X Maps? As long as we are consistent with something in the system =).
Comment 4 Timothy Hatcher 2014-01-18 00:35:54 PST
*** Bug 14378 has been marked as a duplicate of this bug. ***
Comment 5 Radar WebKit Bug Importer 2014-01-18 01:03:37 PST
<rdar://problem/15852729>
Comment 6 Timothy Hatcher 2014-01-20 19:02:52 PST
https://trac.webkit.org/changeset/162409