Bug 125684 - [GTK] [CMake] Build the WebKit1 GObject API tests
Summary: [GTK] [CMake] Build the WebKit1 GObject API tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
: 116730 (view as bug list)
Depends on:
Blocks: 115966
  Show dependency treegraph
 
Reported: 2013-12-13 00:51 PST by Martin Robinson
Modified: 2013-12-24 12:47 PST (History)
5 users (show)

See Also:


Attachments
Patch (18.02 KB, patch)
2013-12-20 17:59 PST, Martin Robinson
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-12 for mac-mountainlion-wk2 (530.55 KB, application/zip)
2013-12-20 22:30 PST, Build Bot
no flags Details
Patch (18.03 KB, patch)
2013-12-22 13:12 PST, Martin Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2013-12-13 00:51:05 PST
We need CMake to build the WebKit1 GObject API tests.
Comment 1 Martin Robinson 2013-12-20 17:59:19 PST
Created attachment 219819 [details]
Patch
Comment 2 Build Bot 2013-12-20 22:30:23 PST
Comment on attachment 219819 [details]
Patch

Attachment 219819 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/49688092

New failing tests:
plugins/quicktime-plugin-replacement.html
Comment 3 Build Bot 2013-12-20 22:30:25 PST
Created attachment 219838 [details]
Archive of layout-test-results from webkit-ews-12 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-12  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 4 Martin Robinson 2013-12-21 06:28:47 PST
I'm almost certain the Mac failure is unrelated.
Comment 5 Gustavo Noronha (kov) 2013-12-22 12:47:47 PST
Comment on attachment 219819 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=219819&action=review

> Source/WebKit/gtk/tests/CMakeLists.txt:17
> +macro(ADD_GOBJECT_TEST test_name)

This is a nice advantage over automake.
Comment 6 Martin Robinson 2013-12-22 13:12:56 PST
Created attachment 219885 [details]
Patch
Comment 7 Daniel Bates 2013-12-23 13:31:32 PST
Comment on attachment 219885 [details]
Patch

Looks sane to me.
Comment 8 Martin Robinson 2013-12-23 13:45:20 PST
Comment on attachment 219885 [details]
Patch

Clearing flags on attachment: 219885

Committed r161015: <http://trac.webkit.org/changeset/161015>
Comment 9 Martin Robinson 2013-12-23 13:45:24 PST
All reviewed patches have been landed.  Closing bug.
Comment 10 Martin Robinson 2013-12-24 12:47:05 PST
*** Bug 116730 has been marked as a duplicate of this bug. ***