Bug 12563 - Duplication of Inserted Korean letter in HTML INPUT element
Summary: Duplication of Inserted Korean letter in HTML INPUT element
Status: RESOLVED DUPLICATE of bug 12531
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-03 17:57 PST by Hyeonseok Shin
Modified: 2007-02-03 23:30 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hyeonseok Shin 2007-02-03 17:57:17 PST
If I press "R" key to insert "ㄱ" in Korean, "ㄲㄱ'' is inserted. I think the previous version of webkit (maybe before 19300) do not have this bug.

Here is a key list.

key | required result | actual reault

q | ㅂ | ㅃㅂ
w | ㅈ | ㅉㅈ
e | ㄷ | ㄸㄷ
r | ㄱ | ㄲㄱ
t | ㅅ | ㅆㅅ
y | ㅛ | ㅛㅛ
u | ㅕ | ㅕㅕ
i | ㅑ | ㅑㅑ
o | ㅐ | ㅐㅐ
p | ㅔ | ㅔㅔ
a | ㅁ | ㅁㅁ
s | ㄴ | ㄴㄴ
d | ㅇ | ㅇㅇ
f | ㄹ | ㄹㄹ
g | ㅎ | ㅎㅎ
h | ㅗ | ㅗㅗ
j | ㅓ | ㅓㅓ
k | ㅏ | ㅏㅏ
l | ㅣ | ㅣㅣ
z | ㅋ | ㅋㅋ
x | ㅌ | ㅌㅌ
c | ㅊ | ㅊㅊ
v | ㅍ | ㅍㅍ
b | ㅠ | ㅠㅠ
n | ㅜ | ㅜㅜ
m | ㅡ | ㅡㅡ
Comment 1 Alexey Proskuryakov 2007-02-03 23:30:07 PST

*** This bug has been marked as a duplicate of 12531 ***