Bug 125340 - PageConsole::addMessage does not set position in every cases.
Summary: PageConsole::addMessage does not set position in every cases.
Status: RESOLVED DUPLICATE of bug 105280
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-06 01:05 PST by László Langó
Modified: 2015-01-16 16:48 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description László Langó 2013-12-06 01:05:23 PST
WebCore/page/PageConsole.cpp:

FIXME: The below code attempts to determine line numbers for parser generated errors, but this is not the only reason why we can get here. For example, if we are still parsing and get a WebSocket network error, it will be erroneously attributed to a line where parsing was paused. Also, we should determine line numbers for script generated messages (e.g. calling getImageData on a canvas). We probably need to split this function into multiple ones, as appropriate for different call sites. Or maybe decide based on MessageSource.
Comment 1 Alexey Proskuryakov 2015-01-16 16:48:36 PST
> Also, we should determine line numbers for script generated messages (e.g. calling getImageData on a canvas).

This works now, as we reuse ConsoleMessage's processing to get the code location.

> For example, if we are still parsing and get a WebSocket network error, it will be erroneously attributed to a line where parsing was paused.

This is bug 105280.

*** This bug has been marked as a duplicate of bug 105280 ***