DragImage.h and the functions in it are used in lots of places besides dragging code. It should be renamed to something like RenderedImage while retaining platform typedefs. Then, dragging-related callsites can pass parameters to enable drag-specific rendering.
I would like feedback on this before I go do 500 renamings. What should we do about functions that are only used for dragging (in particular, link and image previews, and the various scaling/dissolving ops)? Should they be named createRenderedImageForLink? In that case, it's implicit that they are doing some extra rendering to make it look pretty for dragging. Maybe the drag-specific things can stay in DragImage.h and non-drag things (and the typedef) can go into RenderedImage.h
DragImageRef could be PlatformImageRef. It doesn't really have anything to do with renderers.
(In reply to comment #2)
> DragImageRef could be PlatformImageRef. It doesn't really have anything to do with renderers.
That makes sense. So it would be similar to PlatformLayer, then.