RESOLVED FIXED 125052
Instead of watchpointing activation allocation, we should watchpoint entry into functions that have captured variables
https://bugs.webkit.org/show_bug.cgi?id=125052
Summary Instead of watchpointing activation allocation, we should watchpoint entry in...
Filip Pizlo
Reported 2013-12-01 18:15:42 PST
Patch forthcoming.
Attachments
stuff (13.05 KB, patch)
2013-12-01 18:23 PST, Filip Pizlo
no flags
the patch (15.54 KB, patch)
2013-12-01 18:53 PST, Filip Pizlo
mhahnenberg: review+
Filip Pizlo
Comment 1 2013-12-01 18:23:45 PST
Filip Pizlo
Comment 2 2013-12-01 18:53:09 PST
Created attachment 218131 [details] the patch
WebKit Commit Bot
Comment 3 2013-12-01 18:54:57 PST
Attachment 218131 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source/JavaScriptCore/bytecode/BytecodeLivenessAnalysis.cpp', u'Source/JavaScriptCore/bytecode/CodeBlock.cpp', u'Source/JavaScriptCore/bytecode/Opcode.h', u'Source/JavaScriptCore/bytecode/Watchpoint.h', u'Source/JavaScriptCore/bytecompiler/BytecodeGenerator.cpp', u'Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp', u'Source/JavaScriptCore/dfg/DFGCapabilities.cpp', u'Source/JavaScriptCore/dfg/DFGWatchpointCollectionPhase.cpp', u'Source/JavaScriptCore/jit/JIT.cpp', u'Source/JavaScriptCore/jit/JIT.h', u'Source/JavaScriptCore/jit/JITOpcodes.cpp', u'Source/JavaScriptCore/llint/LowLevelInterpreter.asm', u'Source/JavaScriptCore/runtime/CommonSlowPaths.cpp', u'Source/JavaScriptCore/runtime/CommonSlowPaths.h', u'Source/JavaScriptCore/runtime/JSActivation.h', u'Source/JavaScriptCore/runtime/SymbolTable.cpp', u'Source/JavaScriptCore/runtime/SymbolTable.h']" exit_code: 1 Source/JavaScriptCore/jit/JIT.cpp:165: Non-label code inside switch statements should be indented. [whitespace/indent] [4] Total errors found: 1 in 18 files If any of these errors are false positives, please file a bug against check-webkit-style.
Mark Hahnenberg
Comment 4 2013-12-02 10:56:11 PST
Comment on attachment 218131 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=218131&action=review r=me with comments. > Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:3012 > addToGraph(ActivationAllocationWatchpoint, OpInfo(activation->symbolTable())); Maybe rename ActivationAllocationWatchpoint to FunctionReentryWatchpoint? > Source/JavaScriptCore/dfg/DFGWatchpointCollectionPhase.cpp:129 > case ActivationAllocationWatchpoint: Ditto.
Filip Pizlo
Comment 5 2013-12-02 11:06:47 PST
Note You need to log in before you can comment on or make changes to this bug.