Bug 124638 - [Shapes] Caching loop iteration number
Summary: [Shapes] Caching loop iteration number
Status: RESOLVED DUPLICATE of bug 130740
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-19 22:47 PST by Przemyslaw Szymanski
Modified: 2015-11-12 21:03 PST (History)
5 users (show)

See Also:


Attachments
Loop iteration cache (1.56 KB, patch)
2013-11-19 22:50 PST, Przemyslaw Szymanski
no flags Details | Formatted Diff | Diff
Loop iteration cache (1.56 KB, patch)
2013-11-19 22:54 PST, Przemyslaw Szymanski
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Przemyslaw Szymanski 2013-11-19 22:47:01 PST
We can cache loop iteration number in firstIncludedIntervalY method. We can't be sure that every compiler do this for us, and it does not cause any overhead.
Comment 1 Przemyslaw Szymanski 2013-11-19 22:50:28 PST
Created attachment 217388 [details]
Loop iteration cache
Comment 2 Przemyslaw Szymanski 2013-11-19 22:54:39 PST
Created attachment 217389 [details]
Loop iteration cache

changelog update
Comment 3 Tim Horton 2013-11-20 00:50:42 PST
Comment on attachment 217389 [details]
Loop iteration cache

View in context: https://bugs.webkit.org/attachment.cgi?id=217389&action=review

> Source/WebCore/ChangeLog:11
> +        No functionality is changed in this patch.
> +
> +        No new tests. Covered by existing ones.

No tests, no functionality change, no performance numbers, no indication that this is a bottleneck or at all interesting to optimize, and no mention of which compiler doesn't do this hoisting (though, just the same, I have no idea which of them do...). Have you seen this show up in a profiler?
Comment 4 Joseph Pecoraro 2015-11-12 21:02:59 PST
Comment on attachment 217389 [details]
Loop iteration cache

Clearing review flags. This patch is stale as this code was deleted in bug 130740 so duping this to that and closing.
Comment 5 Joseph Pecoraro 2015-11-12 21:03:12 PST

*** This bug has been marked as a duplicate of bug 130740 ***