Bug 12460 - Max-width inheritance doesn't work
Summary: Max-width inheritance doesn't work
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 418.x
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 12396
  Show dependency treegraph
 
Reported: 2007-01-29 08:31 PST by David Latapie
Modified: 2013-07-27 04:01 PDT (History)
5 users (show)

See Also:


Attachments
Tescase (1.79 KB, application/xhtml+xml)
2007-01-29 08:34 PST, David Latapie
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Latapie 2007-01-29 08:31:52 PST
The attached document should have a table more narrow than the text. This happens correctly in Mozilla 3, not in WebKit latest nightly.
Comment 1 David Latapie 2007-01-29 08:34:53 PST
Created attachment 12742 [details]
Tescase
Comment 2 David Kilzer (:ddkilzer) 2007-01-29 09:00:30 PST
Confirmed with a locally-built debug build of WebKit r19207 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Opera 9.10 renders this correctly.  Firefox 2.0.0.1 does not (although David mentioned that Mozilla 3 works).

Comment 3 David Kilzer (:ddkilzer) 2007-01-29 09:05:02 PST
(In reply to comment #2)
> Confirmed with a locally-built debug build of WebKit r19207 with Safari 2.0.4
> (419.3) on Mac OS X 10.4.8 (8N1037).

This is not a regression from shipping Safari as it renders it the same way as ToT WebKit.
Comment 4 David Kilzer (:ddkilzer) 2007-01-29 09:22:54 PST
Moving version back to 418.x since this affects shipping Safari.

David, note that the number in parenthesis in the about Safari window is Safari's build number, not WebKit's.  (I know it's confusing.  I filed a Radar bug about including WebKit's build number in that window in the future.)

Here's a nice chart that describes the WebKit version number given the OS X/Safari build/version numbers:

http://developer.apple.com/internet/safari/uamatrix.html

Comment 5 David Latapie 2007-01-29 09:43:09 PST
(In reply to comment #4)
> Moving version back to 418.x since this affects shipping Safari.
> 
> David, note that the number in parenthesis in the about Safari window is
> Safari's build number, not WebKit's.  (I know it's confusing.  I filed a Radar
> bug about including WebKit's build number in that window in the future.)
> 
> Here's a nice chart that describes the WebKit version number given the OS
> X/Safari build/version numbers:
> 
> http://developer.apple.com/internet/safari/uamatrix.html

Thank you (for suggestion and radar)! I wil select "nightly" in the future.
Comment 6 David Kilzer (:ddkilzer) 2007-01-29 10:34:00 PST
See also Bug 12396.

Comment 7 David Latapie 2012-01-18 15:21:42 PST
This bug still holds true today (I checked with Firefox too).
Comment 8 Robert Hogan 2013-07-27 01:37:27 PDT
David, the testcase looks fine to me now on WebKit trunk. Can you close if you agree?
Comment 9 David Latapie 2013-07-27 04:01:49 PDT
Works for me too on Chrome 28 (I dont use Mac anymore). I guess 28 still is still webkit-powered, not Blink-powered . I mark it as RESOLVED FIXED.
(woohoo, my very first RESOLVED FIXED :))