Bug 12455 - Bullets misaligned vertically and horizontally on web page
Summary: Bullets misaligned vertically and horizontally on web page
Status: RESOLVED DUPLICATE of bug 13157
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, NeedsReduction
Depends on:
Blocks:
 
Reported: 2007-01-28 19:09 PST by David Kilzer (:ddkilzer)
Modified: 2007-03-22 20:49 PDT (History)
3 users (show)

See Also:


Attachments
CIA screenshot #1 (141.32 KB, image/png)
2007-01-31 04:39 PST, David Kilzer (:ddkilzer)
no flags Details
CIA screenshot #2 (135.94 KB, image/png)
2007-01-31 04:40 PST, David Kilzer (:ddkilzer)
no flags Details
CIA screenshot #3 (122.50 KB, image/png)
2007-01-31 04:42 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-01-28 19:09:58 PST
Summary:

The bullets in the first section of the page are misaligned (both horizontally and vertically) on various lines.

Steps to reproduce:

1. Open Safari/WebKit.
2. Note position of bullets in first section.

Expected results:

Bullets should align vertically, and they should align horizontally with the first line of text that they're associated with.

Actual results:

Bullets aren't aligned vertically or horizontally.

Regression:

This works with shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).  Regression occurs with a locally-built debug build of WebKit r19202 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Notes:

None.
Comment 1 David Kilzer (:ddkilzer) 2007-01-28 20:41:41 PST
Okay, now I can't reproduce it with a locally-built debug build of WebKit r19207.

I doubt it was fixed within those revisions, though.  Might have been some kind of FOUC-related episode.

Comment 2 David Kilzer (:ddkilzer) 2007-01-31 04:28:29 PST
I saw this happen again, this time on CIA:

http://cia.navi.cx/stats/project/WebKit

Screenshot forthcoming.  I have no idea how to reproduce it yet.

Comment 3 David Kilzer (:ddkilzer) 2007-01-31 04:39:48 PST
Created attachment 12821 [details]
CIA screenshot #1

Bullets drawn shifted down vertically on CIA.
Comment 4 David Kilzer (:ddkilzer) 2007-01-31 04:40:56 PST
Created attachment 12822 [details]
CIA screenshot #2

More bullets shifted downward on CIA.  This is all the same page.
Comment 5 David Kilzer (:ddkilzer) 2007-01-31 04:42:35 PST
Created attachment 12823 [details]
CIA screenshot #3

Still the same CIA page with shifted bullets.
Comment 6 David Kilzer (:ddkilzer) 2007-01-31 04:44:17 PST
(In reply to comment #0)
> Steps to reproduce:
> 
> 1. Open Safari/WebKit.
1.5 Open URL: http://www.worldsync.com:16080/syncdek/features.html
> 2. Note position of bullets in first section.

I forgot a step in the original reproduction instructions.  I can't get this URL to reproduce on demand, though.
Comment 7 David Kilzer (:ddkilzer) 2007-01-31 04:47:15 PST
One more interesting tidbit: When this happens, scrolling vertically (in either direction) does NOT always redraw the bullets properly (is that "tearing?"), but scrolling horizontally (in either direction) will always redraw the bullets.

Comment 8 Mark Rowe (bdash) 2007-02-01 18:40:48 PST
<rdar://problem/4971213>
Comment 9 David Kilzer (:ddkilzer) 2007-02-06 15:28:18 PST
May have been fixed by r19441.

http://trac.webkit.org/projects/webkit/changeset/19441

Comment 10 John Sullivan 2007-02-12 11:29:26 PST
There are two pages mentioned here:

http://www.worldsync.com:16080/syncdek/features.html

and

http://cia.navi.cx/stats/project/WebKit

The change for r19441 was about list editing rather than just list viewing, so it doesn't seem to be related. However, I can't reproduce a problem on either of these pages, and it sounds like most other people can't either. I'm going to move this to WORKSFORME; please reopen if anyone can still reproduce this.
Comment 11 David Kilzer (:ddkilzer) 2007-03-22 20:45:37 PDT
This is a duplicate of Bug 13157.

Comment 12 David Kilzer (:ddkilzer) 2007-03-22 20:46:47 PDT

*** This bug has been marked as a duplicate of 13157 ***
Comment 13 David Kilzer (:ddkilzer) 2007-03-22 20:49:51 PDT
Was not a regression per Bug 13157.