Bug 124485 - REGRESSION(r159363): [GTK] API break in webkit_dom_html_media_element_set_current_time
Summary: REGRESSION(r159363): [GTK] API break in webkit_dom_html_media_element_set_cur...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Bindings (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2013-11-18 01:35 PST by Carlos Garcia Campos
Modified: 2013-11-18 01:49 PST (History)
4 users (show)

See Also:


Attachments
Patch (4.99 KB, patch)
2013-11-18 01:38 PST, Carlos Garcia Campos
pnormand: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2013-11-18 01:35:56 PST
In r159363 currentTime attribute was changed to not raise exceptions. This breaks the API of GObject DOM bindings because we use a GError parameter for exceptions that has been removed.
Comment 1 Carlos Garcia Campos 2013-11-18 01:38:53 PST
Created attachment 217179 [details]
Patch
Comment 2 Carlos Garcia Campos 2013-11-18 01:49:55 PST
Committed r159406: <http://trac.webkit.org/changeset/159406>