Bug 124348 - Background operation of webaudio in Safari (iOS)
Summary: Background operation of webaudio in Safari (iOS)
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Audio (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Other
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-14 06:07 PST by Leinho
Modified: 2013-11-14 10:37 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leinho 2013-11-14 06:07:53 PST
I would like to generate sounds in HTML5 and to be able to play them on background operation, I mean when the screen is off.

Right now I am able to generate sounds using ScriptProcessor of webAudio API and play them correctly on Safari/Chrome for iOS 7.

The problem is that when I turn the screen off, when using Safari, the sounds are stopped and the sound reproduction is started again when I turn the screen on. This problem does not happen in Chrome, I can listen to them even with the screen off.

Is there something I can do to support this feature in Safari?
Comment 1 Alexey Proskuryakov 2013-11-14 10:31:33 PST
Please file this bug via http://bugreport.apple.com. It is very iOS specific, and tracking it in open source WebKit Bugzilla is not practical.

Please also file a report via http://bugreport.apple.com about how Chrome is not properly suspended and keeps wasting battery even when screen is off. This might be an OS bug that it plays audio under these conditions.
Comment 2 Leinho 2013-11-14 10:37:26 PST
Thank you!

So, should it be suspended? 

I have tested the same app in Chrome using my Android phone and the sounds are still reproduced when the screen is off... 

I thought that background operation should be supported.

(In reply to comment #1)
> Please file this bug via http://bugreport.apple.com. It is very iOS specific, and tracking it in open source WebKit Bugzilla is not practical.
> 
> Please also file a report via http://bugreport.apple.com about how Chrome is not properly suspended and keeps wasting battery even when screen is off. This might be an OS bug that it plays audio under these conditions.