Bug 124280 - REGRESSION(r159180): crypto/subtle/rsassa-pkcs1-v1_5-import-jwk.html is failing on Maverics release bot
Summary: REGRESSION(r159180): crypto/subtle/rsassa-pkcs1-v1_5-import-jwk.html is faili...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks: 122679 124236
  Show dependency treegraph
 
Reported: 2013-11-13 07:19 PST by WebKit Commit Bot
Modified: 2013-11-13 11:17 PST (History)
4 users (show)

See Also:


Attachments
ROLLOUT of r159180 (107.83 KB, patch)
2013-11-13 07:20 PST, WebKit Commit Bot
koivisto: commit-queue-
Details | Formatted Diff | Diff
proposed fix (3.18 KB, patch)
2013-11-13 10:37 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Commit Bot 2013-11-13 07:19:53 PST
http://trac.webkit.org/changeset/159180 broke the build:
crypto/subtle/rsassa-pkcs1-v1_5-import-jwk.html is failing on Maverics release bot (Requested by anttik on #webkit).

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2013-11-13 07:20:15 PST
Created attachment 216799 [details]
ROLLOUT of r159180

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Antti Koivisto 2013-11-13 07:22:52 PST
Skipping the failing test instead
Comment 4 Antti Koivisto 2013-11-13 07:26:06 PST
repurposing
Comment 5 Antti Koivisto 2013-11-13 07:31:00 PST
Skipped in https://trac.webkit.org/r159193
Comment 6 Alexey Proskuryakov 2013-11-13 10:37:03 PST
Created attachment 216819 [details]
proposed fix
Comment 7 Anders Carlsson 2013-11-13 10:47:32 PST
Comment on attachment 216819 [details]
proposed fix

I'd use std::array instead of those C style arrays but r+ anyway!
Comment 8 WebKit Commit Bot 2013-11-13 11:17:34 PST
Comment on attachment 216819 [details]
proposed fix

Clearing flags on attachment: 216819

Committed r159211: <http://trac.webkit.org/changeset/159211>
Comment 9 WebKit Commit Bot 2013-11-13 11:17:36 PST
All reviewed patches have been landed.  Closing bug.