Bug 124148 - REGRESSION(r158976): Web Inspector: unable to start docked or dock
Summary: REGRESSION(r158976): Web Inspector: unable to start docked or dock
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Gustavo Noronha (kov)
URL:
Keywords: InRadar
: 124155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-11 08:07 PST by Gustavo Noronha (kov)
Modified: 2013-11-11 17:53 PST (History)
6 users (show)

See Also:


Attachments
Patch (1.46 KB, patch)
2013-11-11 08:10 PST, Gustavo Noronha (kov)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2013-11-11 08:07:44 PST
With the change in r158976, the canAttach method takes into account the level of inspector that is being started, to avoid starting an inspector instance that is inspecting an inspector on the same window. The first level of inspectors is 1, but canAttach checks for m_level > 0, so we are never able to attach.
Comment 1 Radar WebKit Bug Importer 2013-11-11 08:08:05 PST
<rdar://problem/15437083>
Comment 2 Gustavo Noronha (kov) 2013-11-11 08:10:08 PST
Created attachment 216572 [details]
Patch
Comment 3 Alexandru Chiculita 2013-11-11 10:03:30 PST
*** Bug 124155 has been marked as a duplicate of this bug. ***
Comment 4 Alexandru Chiculita 2013-11-11 10:05:13 PST
Sorry about that. Having the level set to 1 was a last minute change that I've done when the debug build asserted in the HashMap.
Comment 5 WebKit Commit Bot 2013-11-11 17:53:32 PST
Comment on attachment 216572 [details]
Patch

Clearing flags on attachment: 216572

Committed r159090: <http://trac.webkit.org/changeset/159090>
Comment 6 WebKit Commit Bot 2013-11-11 17:53:34 PST
All reviewed patches have been landed.  Closing bug.