Bug 12407 - shadow displayed incorrectly
Summary: shadow displayed incorrectly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.4
: P2 Minor
Assignee: Nobody
URL: http://notes.thinksecret.com/
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-25 11:22 PST by Stephen
Modified: 2007-05-16 11:28 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephen 2007-01-25 11:22:34 PST
the shadow at the bottom of the page is displayed incorrectly, it is four times stacked vertically to the end of the page instead of just shadowing the page.
Comment 1 David Kilzer (:ddkilzer) 2007-01-25 11:44:47 PST
Confirmed with a locally-built debug build of WebKit r19127 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

This is not a regression as the same issue occurs on shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).

Comment 2 David Kilzer (:ddkilzer) 2007-01-25 11:55:00 PST
A quick spin with the DOM inspector makes it appear that this is a table layout issue.

Comment 3 Matt Lilek 2007-01-26 08:43:23 PST
I took a look at this last night and I'm pretty sure this isn't a bug.

It seems that page has some tag soup tables and they mess up a colspan/rowspan here and there that, due to subtle rendering differences between engines, causes us to make the right hand advertising column slightly taller than the main content column and we end up repeating the background on that table cell causing the multiple shadows (non-standard background attribute). If you load it in Firefox and reduce the text size until the right column is taller than the main column, you'll see the same thing.  Opera does the same thing.

Finally, this only happens on that single page, not any other page that I've seen on that site (including the main Thinksecret domain) which makes me think this is just an error on thier end even more.
Comment 4 David Kilzer (:ddkilzer) 2007-01-26 12:43:06 PST
Per Comment #3, changing this to an evangelism bug.  Sent an "anonymous email" to thinksecret.com about the issue.

Comment 5 Matt Lilek 2007-05-16 11:28:11 PDT
Closing as this seems to be fixed.