Bug 123770 - Web Inspector: DOM Breakpoints are not working unless there's JS breakpoint set
Summary: Web Inspector: DOM Breakpoints are not working unless there's JS breakpoint set
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: InspectorTest
  Show dependency treegraph
 
Reported: 2013-11-04 17:05 PST by Alexandru Chiculita
Modified: 2018-09-05 09:43 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandru Chiculita 2013-11-04 17:05:09 PST
The DOM breakpoints are not sent unless there's a previous JS breakpoint set. That's because JSC::Debugger expects a call to incNumberOfBreakpoints when the client needs the runtime to capture debugging information. Otherwise there will be no call frames available when the DOM breakpoints are triggered.
Comment 1 Radar WebKit Bug Importer 2013-11-04 17:05:21 PST
<rdar://problem/15389268>
Comment 2 Timothy Hatcher 2013-11-05 10:05:51 PST
Are you looking to add UI for DOM breakpoints?
Comment 3 Alexandru Chiculita 2013-11-05 13:52:15 PST
I (In reply to comment #2)
> Are you looking to add UI for DOM breakpoints?

I don't have any plans on this yet.

I was working on https://bugs.webkit.org/show_bug.cgi?id=123516 when I've discovered this issue. I'm touching some of the Inspector instrumentation and I thought I need to add a test for this case too.

It took me a while to figure out why the protocol test was not working, so I've added this bug to track the issue.
Comment 4 Devin Rousso 2018-09-05 09:43:00 PDT
I can confirm that DOM breakpoints are working without JS breakpoints.