Bug 12372 - REGRESSION: webView:decidePolicyForNavigationAction: delegate gets wrong URL in WebActionOriginalURLKey
Summary: REGRESSION: webView:decidePolicyForNavigationAction: delegate gets wrong URL ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-01-22 13:39 PST by Bruce Q. Hammond
Modified: 2007-02-08 15:57 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Q. Hammond 2007-01-22 13:39:40 PST
When webView:decidePolicyForNavigationAction:request:frame: is called
[actionInformation objectForKey: WebActionOriginalURLKey] now returns
applewebdata://<bignum>

This used to provide our original request:
file://localhost/<path>/

We belive this broke at or near r17745  nightly (11/13/06)
Comment 1 David Kilzer (:ddkilzer) 2007-01-22 14:07:24 PST
Probably a duplicate of Bug 11961.

Comment 2 Mark Rowe (bdash) 2007-01-28 19:10:25 PST
<rdar://problem/4960265>
Comment 3 Anders Carlsson 2007-02-08 15:57:13 PST
This is either a duplicate of <rdar://problem/4886776> or http://bugs.webkit.org/show_bug.cgi?id=11961 but it's been fixed in any case.