Bug 123715 - [MathML] Center of stretched curly bracket not always vertically centered
Summary: [MathML] Center of stretched curly bracket not always vertically centered
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Martin Robinson
URL:
Keywords:
: 123946 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-03 17:01 PST by Martin Robinson
Modified: 2013-11-08 11:25 PST (History)
9 users (show)

See Also:


Attachments
Patch (92.03 KB, patch)
2013-11-06 19:06 PST, Martin Robinson
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2 (514.68 KB, application/zip)
2013-11-06 19:50 PST, Build Bot
no flags Details
Patch with Mac results (185.02 KB, patch)
2013-11-06 19:53 PST, Martin Robinson
bfulgham: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Robinson 2013-11-03 17:01:34 PST
In some circumstances, the center piece of the stretched curly bracket is not always centered in the area of the stretched bracket. This can be observed in the new version of mathml/presentation/mo-stretch.html from 122837.
Comment 1 Frédéric Wang (:fredw) 2013-11-03 23:19:07 PST
I'm wondering if that's a consequence of bug 119043...
Comment 2 Martin Robinson 2013-11-03 23:53:22 PST
I've tracked this down to a regression caused by my patch. I should have a patch fixing it tomorrow.
Comment 3 Martin Robinson 2013-11-06 18:55:14 PST
*** Bug 123946 has been marked as a duplicate of this bug. ***
Comment 4 Martin Robinson 2013-11-06 18:56:03 PST
A related issue, because it causes the same assertion to fail, is that glyph pieces that directly abut are not handled properly.
Comment 5 Martin Robinson 2013-11-06 19:06:28 PST
Created attachment 216255 [details]
Patch
Comment 6 Build Bot 2013-11-06 19:50:04 PST
Comment on attachment 216255 [details]
Patch

Attachment 216255 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/22538073

New failing tests:
mathml/presentation/mo-stretch.html
Comment 7 Build Bot 2013-11-06 19:50:06 PST
Created attachment 216256 [details]
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-14  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 8 Martin Robinson 2013-11-06 19:53:10 PST
Created attachment 216257 [details]
Patch with Mac results
Comment 9 Brent Fulgham 2013-11-08 09:57:22 PST
Comment on attachment 216257 [details]
Patch with Mac results

r=me
Comment 10 Martin Robinson 2013-11-08 11:25:07 PST
Committed r158931: <http://trac.webkit.org/changeset/158931>