Bug 12354 - REGRESSION (r19005): Safari RSS sidebar jumps around when scrolling
Summary: REGRESSION (r19005): Safari RSS sidebar jumps around when scrolling
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-01-21 15:20 PST by mitz
Modified: 2007-01-21 16:05 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2007-01-21 15:20:06 PST
Since r19005 (fix for bug 8360) the Safari RSS sidebar jumps around when you scroll the main content. It uses a scroll event handler to maintain fixed position, and since the scroll events are delayed until after layout and painting, the initial scrolling is visible before the event handler repositions the "pinned" element.

I suppose many sites that use a similar technique are affected.
Comment 1 Sam Weinig 2007-01-21 16:05:21 PST
Fixed by reverting the changes made in bug 8360.