Bug 123510 - Web Inspector: Add Support for OS X Full Screen Mode
Summary: Web Inspector: Add Support for OS X Full Screen Mode
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Enhancement
Assignee: Joseph Pecoraro
URL:
Keywords: InRadar
: 128529 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-30 06:42 PDT by Carlos
Modified: 2015-06-25 18:47 PDT (History)
4 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (7.73 KB, patch)
2015-06-25 18:18 PDT, Joseph Pecoraro
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos 2013-10-30 06:42:25 PDT
Safari's web inspector does not all for full screen mode, and should for multi-display goodness. Chrome does.
Comment 1 Radar WebKit Bug Importer 2013-10-30 06:42:36 PDT
<rdar://problem/15350912>
Comment 2 Timothy Hatcher 2014-02-10 13:25:32 PST
*** Bug 128529 has been marked as a duplicate of this bug. ***
Comment 3 Joseph Pecoraro 2015-06-25 18:18:41 PDT
Created attachment 255606 [details]
[PATCH] Proposed Fix
Comment 4 Timothy Hatcher 2015-06-25 18:32:19 PDT
Comment on attachment 255606 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=255606&action=review

> Source/WebKit2/UIProcess/mac/WebInspectorProxyMac.mm:317
> +    [window setCollectionBehavior:([window collectionBehavior] | NSWindowCollectionBehaviorFullScreenPrimary)];

Why Primary here and NSWindowCollectionBehaviorFullScreenAllowsTiling above?
Comment 5 Joseph Pecoraro 2015-06-25 18:41:45 PDT
Comment on attachment 255606 [details]
[PATCH] Proposed Fix

View in context: https://bugs.webkit.org/attachment.cgi?id=255606&action=review

>> Source/WebKit2/UIProcess/mac/WebInspectorProxyMac.mm:317
>> +    [window setCollectionBehavior:([window collectionBehavior] | NSWindowCollectionBehaviorFullScreenPrimary)];
> 
> Why Primary here and NSWindowCollectionBehaviorFullScreenAllowsTiling above?

This adds Primary, and then ~5 lines later it adds NSWindowCollectionBehaviorFullScreenAllowsTiling. Both WK1 and WK2 are adding both collection behaviors.
Comment 6 Joseph Pecoraro 2015-06-25 18:47:21 PDT
http://trac.webkit.org/changeset/185978