Bug 12321 - Bold, italic text should be optionally marked up as <b>, <strong>, etc.
Summary: Bold, italic text should be optionally marked up as <b>, <strong>, etc.
Status: RESOLVED DUPLICATE of bug 13490
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-01-18 12:43 PST by Dan Wood
Modified: 2008-02-01 12:58 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Wood 2007-01-18 12:43:52 PST
To reproduce:

0. Launch Blot_editableDiv_showSource, my modified version of "Blot" available from <http://dan.karelia.com/webkit/Blot_editableDiv_showSource.zip> with DYLD_FRAMEWORK_PATH pointing to TOT.  (I'm using r18941)

1. Click on the top panel
2. Type some text
3. Select some of it
4. Hit command-B.
5. Likewise, make something italic

Result:  The bolded text is surrounded in a verbose, heavy span, e.g.: <span class="Apple-style-span" style="font-weight: bold;">webkats</span>

There needs to be a programable ability to specify that bold/italic text should be marked up as <b>/<i> or <strong>/<em> instead of the font-weight style span

Note also that the internal apple class should not be there.
Comment 1 Mark Rowe (bdash) 2008-01-12 19:10:25 PST
<rdar://problem/5685602>
Comment 2 Justin Garcia 2008-02-01 12:58:25 PST
This will be address by:

<https://bugs.webkit.org/show_bug.cgi?id=13490> Implement execCommand("styleWithCSS", ...)

*** This bug has been marked as a duplicate of 13490 ***