Bug 123100 - [CSS Regions] calling requestFullscreen() on video flowed in region results in black screen
Summary: [CSS Regions] calling requestFullscreen() on video flowed in region results i...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: AdobeTracked
Depends on: 120457
Blocks: 57312
  Show dependency treegraph
 
Reported: 2013-10-21 10:11 PDT by Mihai Balan
Modified: 2014-04-10 05:09 PDT (History)
2 users (show)

See Also:


Attachments
Zip with testcase (4.88 MB, application/zip)
2013-10-21 10:11 PDT, Mihai Balan
no flags Details
Zip with testcase (1.72 MB, application/zip)
2013-10-21 10:49 PDT, Mihai Balan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Balan 2013-10-21 10:11:48 PDT
Created attachment 214748 [details]
Zip with testcase

Calling webkitRequestFulscreen() on a video element flowed in a region results in a black full screen. It is possible to leave fullscreen, though.

Most likely related to work in bug 120457 since it doesn't reproduce in Safari 6.1.

Attachment is a zip since requestFullScreen() doesn't seem to play nicely with jsfiddle's embedding mechanism.
Comment 1 Mihai Balan 2013-10-21 10:49:43 PDT
Created attachment 214750 [details]
Zip with testcase

Previous attachment had a broken structure.
Comment 2 Mihnea Ovidenie 2014-04-10 05:09:18 PDT
Not reproducible in nightly 167020