RESOLVED FIXED 122940
A CodeBlock's StructureStubInfos shouldn't be in a Vector that we search using code origins and machine code PCs
https://bugs.webkit.org/show_bug.cgi?id=122940
Summary A CodeBlock's StructureStubInfos shouldn't be in a Vector that we search usin...
Filip Pizlo
Reported 2013-10-16 21:49:57 PDT
Patch forthcoming.
Attachments
work in progress (50.54 KB, patch)
2013-10-17 15:23 PDT, Filip Pizlo
no flags
getting close (69.19 KB, patch)
2013-10-17 19:49 PDT, Filip Pizlo
no flags
sort of starting to compile (90.99 KB, patch)
2013-10-17 20:38 PDT, Filip Pizlo
no flags
it compiles! (98.47 KB, patch)
2013-10-17 23:55 PDT, Filip Pizlo
no flags
the patch (116.55 KB, patch)
2013-10-18 18:19 PDT, Filip Pizlo
no flags
the patch (116.55 KB, patch)
2013-10-18 18:40 PDT, Filip Pizlo
no flags
the patch (116.54 KB, patch)
2013-10-18 18:42 PDT, Filip Pizlo
oliver: review+
Filip Pizlo
Comment 1 2013-10-17 15:23:56 PDT
Created attachment 214520 [details] work in progress
Filip Pizlo
Comment 2 2013-10-17 19:49:31 PDT
Created attachment 214540 [details] getting close Still have a bunch of gluing to do...
Filip Pizlo
Comment 3 2013-10-17 20:38:15 PDT
Created attachment 214541 [details] sort of starting to compile
Filip Pizlo
Comment 4 2013-10-17 23:55:20 PDT
Created attachment 214543 [details] it compiles! And of course it doesn't work at all, yet.
Oliver Hunt
Comment 5 2013-10-18 08:48:18 PDT
(In reply to comment #4) > Created an attachment (id=214543) [details] > it compiles! > > And of course it doesn't work at all, yet. Details, details. RS=me :D
Oliver Hunt
Comment 6 2013-10-18 09:18:17 PDT
Comment on attachment 214543 [details] it compiles! View in context: https://bugs.webkit.org/attachment.cgi?id=214543&action=review > Source/WTF/wtf/BagToHashMap.h:35 > +void toHashMap(Bag<ElementType>& bag, KeyGetterFunctor& getKey, HashMap<KeyType, ElementType*>& result) const Bag&?
Filip Pizlo
Comment 7 2013-10-18 18:15:04 PDT
(In reply to comment #6) > (From update of attachment 214543 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=214543&action=review > > > Source/WTF/wtf/BagToHashMap.h:35 > > +void toHashMap(Bag<ElementType>& bag, KeyGetterFunctor& getKey, HashMap<KeyType, ElementType*>& result) > > const Bag&? Then I'd have to add const versions of Bag's iterator. If we ever find this to be a worthwhile thing to do then we can do it.
Filip Pizlo
Comment 8 2013-10-18 18:19:06 PDT
Created attachment 214627 [details] the patch
WebKit Commit Bot
Comment 9 2013-10-18 18:20:21 PDT
Attachment 214627 [details] did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source/JavaScriptCore/bytecode/CodeBlock.cpp', u'Source/JavaScriptCore/bytecode/CodeBlock.h', u'Source/JavaScriptCore/bytecode/CodeOrigin.h', u'Source/JavaScriptCore/bytecode/GetByIdStatus.cpp', u'Source/JavaScriptCore/bytecode/GetByIdStatus.h', u'Source/JavaScriptCore/bytecode/PutByIdStatus.cpp', u'Source/JavaScriptCore/bytecode/PutByIdStatus.h', u'Source/JavaScriptCore/bytecode/StructureStubInfo.h', u'Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp', u'Source/JavaScriptCore/dfg/DFGJITCompiler.cpp', u'Source/JavaScriptCore/dfg/DFGJITCompiler.h', u'Source/JavaScriptCore/dfg/DFGSpeculativeJIT.cpp', u'Source/JavaScriptCore/dfg/DFGSpeculativeJIT.h', u'Source/JavaScriptCore/dfg/DFGSpeculativeJIT32_64.cpp', u'Source/JavaScriptCore/dfg/DFGSpeculativeJIT64.cpp', u'Source/JavaScriptCore/jit/CCallHelpers.h', u'Source/JavaScriptCore/jit/JIT.cpp', u'Source/JavaScriptCore/jit/JIT.h', u'Source/JavaScriptCore/jit/JITInlines.h', u'Source/JavaScriptCore/jit/JITOperations.cpp', u'Source/JavaScriptCore/jit/JITOperations.h', u'Source/JavaScriptCore/jit/JITPropertyAccess.cpp', u'Source/JavaScriptCore/jit/JITPropertyAccess32_64.cpp', u'Source/JavaScriptCore/jit/Repatch.cpp', u'Source/WTF/ChangeLog', u'Source/WTF/GNUmakefile.list.am', u'Source/WTF/WTF.vcxproj/WTF.vcxproj', u'Source/WTF/WTF.xcodeproj/project.pbxproj', u'Source/WTF/wtf/BagToHashMap.h', u'Source/WTF/wtf/CMakeLists.txt']" exit_code: 1 Source/JavaScriptCore/bytecode/GetByIdStatus.h:74: The parameter name "map" adds no information, so it should be removed. [readability/parameter_name] [5] Source/JavaScriptCore/bytecode/CodeBlock.h:929: The parameter name "map" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 2 in 31 files If any of these errors are false positives, please file a bug against check-webkit-style.
Filip Pizlo
Comment 10 2013-10-18 18:40:38 PDT
Created attachment 214628 [details] the patch
Filip Pizlo
Comment 11 2013-10-18 18:42:22 PDT
Created attachment 214629 [details] the patch
Oliver Hunt
Comment 12 2013-10-18 18:53:25 PDT
Comment on attachment 214629 [details] the patch View in context: https://bugs.webkit.org/attachment.cgi?id=214629&action=review > Source/WTF/wtf/CMakeLists.txt:7 > + BatToHashMap.h Halloween already?
Filip Pizlo
Comment 13 2013-10-18 19:18:51 PDT
Note You need to log in before you can comment on or make changes to this bug.