Bug 12254 - FCKeditor: Panels of toolbar items appear in wrong position
Summary: FCKeditor: Panels of toolbar items appear in wrong position
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.fckeditor.net/nightly/brow...
Keywords:
Depends on:
Blocks: 9915
  Show dependency treegraph
 
Reported: 2007-01-13 03:47 PST by Frederico Caldeira Knabben
Modified: 2007-03-09 02:58 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederico Caldeira Knabben 2007-01-13 03:47:20 PST
The panels for the combos and color selectors in the toolbar are being displayed in the wrong position.
Comment 1 A K Sinha 2007-02-20 00:39:53 PST
I could observe it in Mozilla (at least in v1.7 and v2.0) in Windows XP platform.
Comment 2 A K Sinha 2007-02-20 00:53:59 PST
(In reply to comment #1)
> I could observe it in Mozilla (at least in v1.7 and v2.0) in Windows XP
> platform.
> 

I am using version 2.3.1; Build-1062.
Comment 3 Frederico Caldeira Knabben 2007-02-20 02:28:48 PST
(In reply to comment #2)
> (In reply to comment #1)
> > I could observe it in Mozilla (at least in v1.7 and v2.0) in Windows XP
> > platform.
> > 
> 
> I am using version 2.3.1; Build-1062.
> 

Be sure to test it with the URL provided in this report:
http://www.fckeditor.net/nightly/browsers_test.html

We have working on some panel positioning fixes since version 2.3.1.
Comment 4 A K Sinha 2007-03-01 08:19:18 PST
> 
> Be sure to test it with the URL provided in this report:
> http://www.fckeditor.net/nightly/browsers_test.html
> 
> We have working on some panel positioning fixes since version 2.3.1.
> 

Thanks a lot for your response. The URL in the report is working fine. But let me be more specific with my problem.

I am using FCKEditor with Google Web Toolkit (GWT). And the panels which are popped up if we click on tool bars like Styles or Font etc are being wrongly positioned only if it is being used inside a Popup panel or a Dialog box. Otherwise it behaves fine, I mean if it is used inside normal browser window, positions of those panels are correct.

Comment 5 Frederico Caldeira Knabben 2007-03-01 09:08:04 PST
(In reply to comment #4)
> Thanks a lot for your response. The URL in the report is working fine. But let
> me be more specific with my problem.

I believe we are using the wrong discussion channel. This site is dedicated to WebKit bugs, and has nothing to do with FCKeditor directly.

I would ask you to please open a ticket regarding your issue at the FCKeditor development web site:
http://dev.fckeditor.net
Comment 6 Frederico Caldeira Knabben 2007-03-09 02:09:41 PST
I'm not anymore able to reproduce this one with the latest nightly. I can't point the fixing release, but I'm closing it for now.
Comment 7 A K Sinha 2007-03-09 02:58:56 PST
(In reply to comment #6)
> I'm not anymore able to reproduce this one with the latest nightly. I can't
> point the fixing release, but I'm closing it for now.
> 

I've posted the bug on the development site ( http://dev.fckeditor.net/ticket/161 ).
For now I've found the work around, so its fine. I may be looking into the actual fix later.

Thank you.
ashish