Bug 122477 - Make buildRelatedNodeMap and findRelatedNode static to EventRetargeter.cpp
Summary: Make buildRelatedNodeMap and findRelatedNode static to EventRetargeter.cpp
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: UI Events (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-07 18:17 PDT by Ryosuke Niwa
Modified: 2013-10-08 00:08 PDT (History)
7 users (show)

See Also:


Attachments
Cleanup (7.05 KB, patch)
2013-10-07 18:23 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff
Minor bug fix (7.46 KB, patch)
2013-10-07 18:26 PDT, Ryosuke Niwa
koivisto: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-10-07 18:17:12 PDT
Make buildRelatedNodeMap and findRelatedNode static to EventRetargeter.cpp
Comment 1 Ryosuke Niwa 2013-10-07 18:23:01 PDT
Created attachment 213636 [details]
Cleanup
Comment 2 Ryosuke Niwa 2013-10-07 18:26:36 PDT
Created attachment 213637 [details]
Minor bug fix
Comment 3 Antti Koivisto 2013-10-07 18:32:07 PDT
Comment on attachment 213637 [details]
Minor bug fix

View in context: https://bugs.webkit.org/attachment.cgi?id=213637&action=review

> Source/WebCore/dom/EventRetargeter.cpp:184
> +static void buildRelatedNodeMap(const Node* relatedNode, HashMap<TreeScope*, Node*>& relatedNodeMap)

I wish these had more descriptive names. Related to what and how? Same applies to variable names in this code.

> Source/WebCore/dom/EventRetargeter.h:65
>      typedef Vector<RefPtr<Node> > AdjustedNodes;

Would be nice to remove this opaque typedef too.
Comment 4 Ryosuke Niwa 2013-10-07 19:03:03 PDT
Comment on attachment 213637 [details]
Minor bug fix

View in context: https://bugs.webkit.org/attachment.cgi?id=213637&action=review

>> Source/WebCore/dom/EventRetargeter.cpp:184
>> +static void buildRelatedNodeMap(const Node* relatedNode, HashMap<TreeScope*, Node*>& relatedNodeMap)
> 
> I wish these had more descriptive names. Related to what and how? Same applies to variable names in this code.

I think they're referring to https://developer.mozilla.org/en-US/docs/Web/API/event.relatedTarget
but I agree it'll be nice if we could come up with a better name.
Comment 5 Ryosuke Niwa 2013-10-07 20:38:01 PDT
Committed r157083: <http://trac.webkit.org/changeset/157083>