Bug 12222 - REGRESSION (r18790): WebKit crash when going to GMail/Google Mail (redirection)
Summary: REGRESSION (r18790): WebKit crash when going to GMail/Google Mail (redirection)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.4
: P1 Major
Assignee: Nobody
URL: https://gmail.google.com/gmail
Keywords: Regression
: 12231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-12 07:38 PST by Benjamin Kuperman
Modified: 2007-01-12 13:10 PST (History)
2 users (show)

See Also:


Attachments
Crash Log (30.06 KB, text/plain)
2007-01-12 07:39 PST, Benjamin Kuperman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Kuperman 2007-01-12 07:38:41 PST
I've got a bookmark that goes to GMail

https://gmail.google.com/gmail

The browser usually goes through a few redirections before it loads up Google Mail.  I've had no problems with this URL until I upgraded to the current nightly build (18794) which now causes the browser to crash when I go to that url either by bookmark or by pasting in that URL into the address box.
Comment 1 Benjamin Kuperman 2007-01-12 07:39:29 PST
Created attachment 12384 [details]
Crash Log
Comment 2 David Kilzer (:ddkilzer) 2007-01-12 08:11:35 PST
Probably fixed by r18802.

Comment 3 David Kilzer (:ddkilzer) 2007-01-12 08:19:35 PST
Does not crash when using a locally-built debug build of WebKit r18802 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8L127).

Does crash when using WebKit nightly r18794 with the same Safari and OS X.

Closing as RESOLVED/FIXED.

Comment 4 mitz 2007-01-12 08:22:39 PST
Thanks for the bug report. This regression was fixed in r18802. Unfortunately, a nightly build of that (or any later) revision is not available yet, but I expect one to be up in a few hours.
Comment 5 David Kilzer (:ddkilzer) 2007-01-12 09:58:39 PST
Give it the full regression treatment postmortem!  See Bug 12115.

Comment 6 David Kilzer (:ddkilzer) 2007-01-12 13:10:36 PST
*** Bug 12231 has been marked as a duplicate of this bug. ***