Bug 12183 - table-layout: fixed and 100% cell render improperly
Summary: table-layout: fixed and 100% cell render improperly
Status: RESOLVED DUPLICATE of bug 12115
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: PC OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.fredck.com/bugs/safari/tab...
Keywords:
Depends on:
Blocks: 9915
  Show dependency treegraph
 
Reported: 2007-01-09 06:46 PST by Frederico Caldeira Knabben
Modified: 2007-01-12 01:33 PST (History)
1 user (show)

See Also:


Attachments
Test Case (1.57 KB, text/html)
2007-01-09 06:48 PST, Frederico Caldeira Knabben
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederico Caldeira Knabben 2007-01-09 06:46:07 PST
If you have a table with table-layout:fixed and one of the cells have width:100% the rendering is compromised by the other cells widths.

It is quite difficult to explain in words. The provided URL shows the problem clearly.
Comment 1 Frederico Caldeira Knabben 2007-01-09 06:47:27 PST
It works correctly with Firefox, Opera and IE.

This bug breaks the rendering of the combos in the FCKeditor toolbar.
Comment 2 Frederico Caldeira Knabben 2007-01-09 06:48:27 PST
Created attachment 12332 [details]
Test Case
Comment 3 mitz 2007-01-09 07:20:05 PST
Fixed table layout is hosed. Fixing bug 12115 should take care of it.
Comment 4 mitz 2007-01-12 01:33:35 PST

*** This bug has been marked as a duplicate of 12115 ***