WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
121795
ListHashSet should use std::reverse_iterator for reverse iterators
https://bugs.webkit.org/show_bug.cgi?id=121795
Summary
ListHashSet should use std::reverse_iterator for reverse iterators
Anders Carlsson
Reported
2013-09-23 10:56:45 PDT
ListHashSet should use std::reverse_iterator for reverse iterators
Attachments
Patch
(14.17 KB, patch)
2013-09-23 11:12 PDT
,
Anders Carlsson
koivisto
: review+
Details
Formatted Diff
Diff
View All
Add attachment
proposed patch, testcase, etc.
Anders Carlsson
Comment 1
2013-09-23 11:12:41 PDT
Created
attachment 212369
[details]
Patch
WebKit Commit Bot
Comment 2
2013-09-23 11:15:36 PDT
Attachment 212369
[details]
did not pass style-queue: Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WTF/ChangeLog', u'Source/WTF/wtf/ListHashSet.h', u'Tools/ChangeLog', u'Tools/TestWebKitAPI/Tests/WTF/ListHashSet.cpp']" exit_code: 1 Source/WTF/wtf/ListHashSet.h:78: reverse_iterator is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:79: const_reverse_iterator is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:284: difference_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:285: value_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:288: iterator_category is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:336: difference_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:337: value_type is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Source/WTF/wtf/ListHashSet.h:340: iterator_category is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 8 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Anders Carlsson
Comment 3
2013-09-23 11:30:37 PDT
Committed
r156281
: <
http://trac.webkit.org/changeset/156281
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug