Nearly every use of postNotification passes in a constant boolean value. Readability would improve if we replaced these booleans with enum values that were easier for reviewers to parse.
Created attachment 212381 [details]
Changing postNotification bool argument to enum per "Names" rule #10 in the WebKit coding style guidelines and reviewer feedback.
Comment on attachment 212381 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=212381&action=review
> + if (object && (postTarget == TargetObservableParent))
extra parens here are not necessary
Created attachment 212477 [details]
Thanks for the feedback Chris. I had added the inner parens because I figured it saved people from having to do a mental lookup of operator precedence. Removed.
Comment on attachment 212477 [details]
Clearing flags on attachment: 212477
Committed r156339: <http://trac.webkit.org/changeset/156339>
All reviewed patches have been landed. Closing bug.
*** Bug 112857 has been marked as a duplicate of this bug. ***