Bug 12147 - Linked favicons no longer render in address bar
Summary: Linked favicons no longer render in address bar
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Brady Eidson
URL: http://www.informationgift.com/ud/fav...
Keywords: InRadar, Regression, ReviewedForRadar
: 12002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-06 21:02 PST by Lewis Francis
Modified: 2007-12-11 18:45 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewis Francis 2007-01-06 21:02:37 PST
Using a link tag to specify a favicon different from /favicon.ico fails to render in the address bar. At least, it does so for a multi-icon set (containing 1, 4, 8, and 32-bit icons).  Safari favors the 4-bit icon in the multi-res set. Ideally, Webkit would favor the 32-bit icon. Bug present in latest nightly as of this report.
Comment 1 Brady Eidson 2007-01-08 10:30:33 PST
I think the bug here isn't that we fail to respect the linked icon, or that we "prefer the 4-bit version" -
I believe the bug here is that we grab frame 0 from the image - or the first indexed icon from the icon set - and its the wrong one!

I think we have a radar for this but it's been low priority as we haven't seen this reported in the wild yet.

Lemme see if I can find the radar and/or file one.
Comment 2 Brady Eidson 2007-01-08 10:37:52 PST
<rdar://problem/4680377>

I will bump this up a notch on the priority list.

But a warning!  The algorithm won't be "choose the deepest icon" - it will be "choose the deepest icon of the correct size or, if none is found, choose the deepest icon of the incorrect size" as that is what we did in the previous WebIconDatabase
Comment 3 Brady Eidson 2007-01-08 10:38:13 PST
<rdar://problem/4680377>

I will bump this up a notch on the priority list.

But a warning!  The algorithm won't be "choose the deepest icon" - it will be "choose the deepest icon of the correct size or, if none is found, choose the deepest icon of the incorrect size" as that is what we did in the previous WebIconDatabase
Comment 4 Brady Eidson 2007-01-08 10:38:51 PST
Sorry bout the double post - no clue how that happened...  lame!
Comment 5 David Kilzer (:ddkilzer) 2007-01-08 10:46:19 PST
*** Bug 12002 has been marked as a duplicate of this bug. ***
Comment 6 David Kilzer (:ddkilzer) 2007-01-08 10:51:46 PST
(In reply to comment #5)
> *** Bug 12002 has been marked as a duplicate of this bug. ***

Interesting note from Bug 12002 Comment #0:

Code in WebKit/DOM/WebDOMOperations.m for DOMHTMLLinkElement leads me to
believe that this icon is expected to be loaded (or was loaded at one time)
since saving a WebArchive uses this code path and will try to save the icon to
the WebArchive file (and fail).

It's too bad Bug 11882 hasn't landed yet, or you could write a webarchive test for this.

Comment 7 Lewis Francis 2007-12-11 17:51:44 PST
Both of the issues in this report (sorry about that) appear to be resolved; work as expected for me in both Safari 3 and today's Webkit on Leopard.
Comment 8 David Kilzer (:ddkilzer) 2007-12-11 18:45:26 PST
Marking as RESOLVED/FIXED per Comment #7 and Radar.