Bug 121405 - [GTK] Cannot find WebInspectorUI/UserInterface/Main.html referenced in GResourceBundle.xml
Summary: [GTK] Cannot find WebInspectorUI/UserInterface/Main.html referenced in GResou...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Gustavo Noronha (kov)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-15 15:29 PDT by Xabier Rodríguez Calvar
Modified: 2013-09-18 07:54 PDT (History)
4 users (show)

See Also:


Attachments
Patch (2.10 KB, patch)
2013-09-17 18:24 PDT, Gustavo Noronha (kov)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Xabier Rodríguez Calvar 2013-09-15 15:29:30 PDT
When building WebKit from upstream in GNOME Jhbuild with moduleset 3.10 I am getting this problem

./DerivedSources/WebInspectorUI/GResourceBundle.xml: Error on line 5 char 1: Failed to locate 'Source/WebInspectorUI/UserInterface/Main.html' in any source directory.
Comment 1 Xabier Rodríguez Calvar 2013-09-15 15:31:27 PDT
The autogen.sh is run with the following options that hadn't been a problem so far:

--enable-introspection --disable-static --enable-introspection --disable-gtk-doc --disable-introspection --enable-silent-rules
Comment 2 Gustavo Noronha (kov) 2013-09-15 17:55:10 PDT
Hmm, is that using a specific tarball release?
Comment 3 Xabier Rodríguez Calvar 2013-09-17 05:17:36 PDT
(In reply to comment #2)
> Hmm, is that using a specific tarball release?

No, I just use latest version and to not interfere with my upstream compilation, I just clone it by using

git archive --format=tar svn-trunk | (cd /my/destination/inside/gnome/jhbuild/ && tar xf -)
Comment 4 Gustavo Noronha (kov) 2013-09-17 13:07:06 PDT
And I guess the tarball that's being generated by git archive (I have only recently been introduced to it) not including that file?
Comment 5 Xabier Rodríguez Calvar 2013-09-17 14:09:39 PDT
(In reply to comment #4)
> And I guess the tarball that's being generated by git archive (I have only recently been introduced to it) not including that file?

Nope, the file is there.
Comment 6 Gustavo Noronha (kov) 2013-09-17 18:19:15 PDT
OK, I came up with a theory and it looks like it's correct: this only happens if you have srcdir == builddir (which is why we haven't noticed yet), and is caused by automake helpfully resolving the paths of the dependencies of a target, thus removing the useless ./ (that is $(srcdir), which is used to form $(WebInspectorUI)), but keeps that useless ./ in the actual WebInspectorUI variable, so my sed for normalizing the paths was not replacing anything in that case. Patch incoming, just testing with srcdir != builddir now.
Comment 7 Gustavo Noronha (kov) 2013-09-17 18:24:34 PDT
Created attachment 211962 [details]
Patch
Comment 8 WebKit Commit Bot 2013-09-17 23:50:55 PDT
Comment on attachment 211962 [details]
Patch

Clearing flags on attachment: 211962

Committed r156027: <http://trac.webkit.org/changeset/156027>
Comment 9 WebKit Commit Bot 2013-09-17 23:50:57 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Alexey Proskuryakov 2013-09-18 00:09:28 PDT
I wonder why commit queue didn't use your e-mail for this commit: <http://trac.webkit.org/changeset/156027>.

Perhaps your data in committers.json is not up to date?
Comment 11 Gustavo Noronha (kov) 2013-09-18 07:54:58 PDT
It seems to be up-to-date, that file has my name and the gns@gnome.org email. I wonder if the svn post-commit script is only rewriting the email used as username for committing (that would be kov@webkit.org)