We need to rename shapeContainingBlockHeight to shapeContainingBlockLogicalHeight, since it returns the containing block's logical height.
Created attachment 211465 [details]
Created attachment 211469 [details]
Comment on attachment 211469 [details]
Clearing flags on attachment: 211469
Committed r155655: <http://trac.webkit.org/changeset/155655>
All reviewed patches have been landed. Closing bug.