Bug 121084 - WebKit r155375 nightly build crash!
Summary: WebKit r155375 nightly build crash!
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: PDF (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.8
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 00:33 PDT by Ron Abraham
Modified: 2013-09-10 22:34 PDT (History)
2 users (show)

See Also:


Attachments
bug report on webkit nightly build crash (32.91 KB, text/plain)
2013-09-10 09:38 PDT, Ron Abraham
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ron Abraham 2013-09-10 00:33:22 PDT
Hi,
I am a newbie to Webkit.
I downloaded the latest release and it is crashing the moment i launch.
Not sure what i must do hence just filing a bug report.

attaching the crash report.

Thanks
Ron.
Comment 1 Ron Abraham 2013-09-10 00:34:13 PDT
this is on Mac OS X 10.8.2 on my Macbook Pro.
Comment 2 Zan Dobersek 2013-09-10 03:52:45 PDT
The crash report is missing.
Comment 3 Alexey Proskuryakov 2013-09-10 09:34:43 PDT
I cannot reproduce with nightly r155445 on 10.8.4. Please attach your crash log. Also, please note that WebKit nightlies are only expected to work on latest point release of OS X, so please install 10.8.4.
Comment 4 Ron Abraham 2013-09-10 09:38:31 PDT
Created attachment 211206 [details]
bug report on webkit nightly build crash

adding the crash report again..
Comment 5 Alexey Proskuryakov 2013-09-10 09:47:57 PDT
Thank you!

Yes, this crash occurs because of an old OS X version. Please update to 10.8.4.
Comment 6 Ron Abraham 2013-09-10 09:51:23 PDT
ok thanks for the resolution.
i can only test this later then..

i guess this issue can be closed for now..
Comment 7 Ron Abraham 2013-09-10 21:19:42 PDT
I have a related question though, do i need to open a separate ticket ?
I am also not able to build webkit on my 10.8.2 system.

following is the error log after downloading webkit from svn and executing 
$build-webkit --debug

http://pastebin.com/w1KEXfHA


advice would be helpful to me :D

Thanks
Ron.
Comment 8 Alexey Proskuryakov 2013-09-10 21:49:36 PDT
Normally, such questions should be asked on webkit-help mailing list.

But in this case, I can answer it quickly, it's just the same issue as the crash that you observe with nightlies -  WebKit requires functionality that was not present in 10.8.2.

Out of curiosity, what is your reason to use 10.8.2? There were many important fixes since then, including security ones.
Comment 9 Ron Abraham 2013-09-10 21:51:37 PDT
thanks alex. 
i just had to ask the question in relation thats all :D.
i will be doing an update of my os considering its criticality.
Comment 10 Ron Abraham 2013-09-10 22:34:23 PDT
final update - have updated OS to 10.8.4
latest nightly build of webkit WebKit-SVN-r155494.dmg working fine.
thanks for the help.