Bug 121034 - MediaStreamDescriptor::removeAudioComponent accidentally changes m_videoComponents
Summary: MediaStreamDescriptor::removeAudioComponent accidentally changes m_videoCompo...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-09 10:53 PDT by Thiago de Barros Lacerda
Modified: 2013-09-09 14:46 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.68 KB, patch)
2013-09-09 10:55 PDT, Thiago de Barros Lacerda
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago de Barros Lacerda 2013-09-09 10:53:59 PDT
removeAudioComponent is calling remove in video components vector by mistake
Comment 1 Thiago de Barros Lacerda 2013-09-09 10:55:30 PDT
Created attachment 211057 [details]
Patch
Comment 2 Alexey Proskuryakov 2013-09-09 12:39:04 PDT
Re-titled - we use bracketed prefixes for special interest bugs that most people just want to quickly skip over (like platform specific issues).
Comment 3 WebKit Commit Bot 2013-09-09 14:31:50 PDT
Comment on attachment 211057 [details]
Patch

Clearing flags on attachment: 211057

Committed r155382: <http://trac.webkit.org/changeset/155382>
Comment 4 WebKit Commit Bot 2013-09-09 14:31:52 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Darin Adler 2013-09-09 14:41:48 PDT
Comment on attachment 211057 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=211057&action=review

> Source/WebCore/ChangeLog:8
> +        No new tests needed.

Why? Looks like this was a bad bug. Normally we’d want a regression test.
Comment 6 Thiago de Barros Lacerda 2013-09-09 14:46:47 PDT
(In reply to comment #5)
> (From update of attachment 211057 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=211057&action=review
> 
> > Source/WebCore/ChangeLog:8
> > +        No new tests needed.
> 
> Why? Looks like this was a bad bug. Normally we’d want a regression test.

Darin, this was just introduced by accident in this revision https://bugs.webkit.org/show_bug.cgi?id=120872. So I think does not need an Test for that