Bug 120907 - Assertion fails with backslashes in at-rule names
Summary: Assertion fails with backslashes in at-rule names
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-09-06 16:12 PDT by Vicki Pfau
Modified: 2016-12-07 09:44 PST (History)
4 users (show)

See Also:


Attachments
Repro (21 bytes, text/html)
2013-09-06 16:12 PDT, Vicki Pfau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vicki Pfau 2013-09-06 16:12:34 PDT
Created attachment 210812 [details]
Repro

A backslash in the name of an at-rule can cause the parser to fail an assertion (name[0] == '@' && length >= 2) in CSSParser::detectAtToken(int, bool). A simple repro is attached.

<rdar://problem/14911223>
Comment 1 zalan 2016-12-07 09:44:12 PST
I can't reproduce this assertion with r209442.