Bug 12084 - Incomplete repaint when moving from page with large body margin to page with large font size
Summary: Incomplete repaint when moving from page with large body margin to page with ...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-01-02 15:54 PST by Mark Rowe (bdash)
Modified: 2007-03-07 06:35 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2007-01-02 15:54:12 PST
<html>
<head>
    <title>Test HTML Page</title>
    <script type="text/javascript">
        var l = window.location.toString();
        if (l[l.length - 1] == 'X')
            document.write('<style type="text/css">menu { font-size: 985902680pt; }</style>');
        else {
            document.write('<style type="text/css">body { margin: 660402812px; }</style>');
            window.onload = function() {
                var x = document.documentElement.offsetHeight;
                window.setTimeout(function () { location += "?X"; }, 100);
            }
        }
    </script>
</head>
<body>
    <script type="text/javascript">
        var l = window.location.toString();
        if (l[l.length - 1] != 'X')
            document.write('<h1>This should go away after the redirect</h1>')
    </script>
    <menu>menu</menu>
</body>
</html>


Steps to reproduce:
1. Load the file in your browser.
2. Wait for it to reload with an '?X' on the end of the URL.
3. Note that the top 10 or 15 pixels contains remnants of the text 'This should go away after the redirect'.
Comment 1 Mark Rowe (bdash) 2007-01-02 15:58:06 PST
This doesn't occur with WebKit 418.9.1.
Comment 2 Mark Rowe (bdash) 2007-01-02 15:59:13 PST
I lied.  The test case doesn't demonstrate the problem in 418.9.1, but loading the test case then changing to a different tab then back shows that the top few pixels are not repainted.
Comment 3 mitz 2007-03-07 06:23:05 PST
Can't reproduce in TOT.
Comment 4 Mark Rowe (bdash) 2007-03-07 06:35:47 PST
Works for me now too.