Renaming StackIterator to StackVisitor. Also doing some minor refactoring:
- Renamed StackIterator::iterate() to StackVisitor::visit().
- Make StackVisitor::visit() a static method.
- Move the instantiation of the StackVisitor instance into StackVisitor::visit() from CallFrame::iterate().
- Removed StackIterator::resetIterator() and inline its body into the StackVisitor constructor since this is the only remaining caller of it.
Created attachment 210506 [details]
Comment on attachment 210506 [details]
Thanks for the review. Landed in r155081: <http://trac.webkit.org/r155081>.