Bug 120345 - Content is not displayed when the sibling container has CSS transform.
Summary: Content is not displayed when the sibling container has CSS transform.
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac (Intel) OS X 10.8
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-27 01:40 PDT by Martin Wittemann
Modified: 2022-06-11 07:26 PDT (History)
3 users (show)

See Also:


Attachments
HTML file to reproduce the issue (374 bytes, text/html)
2013-08-27 01:40 PDT, Martin Wittemann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wittemann 2013-08-27 01:40:07 PDT
Created attachment 209725 [details]
HTML file to reproduce the issue

The attached html file contains two divs, one having -webkit-backface-visibility: hidden and the other doesn't. Both are embedded in two container divs having position absolute and other properties set (see file). The expected behavior would be that the content texts of both divs are visible but only the one having the backface visibility set is visible.
Comment 1 zalan 2013-08-27 02:17:48 PDT
This is not specific to -webkit-backface-visibilty, so it might be related to bug 101047
Comment 2 Ahmad Saleem 2022-06-11 03:48:55 PDT
I turned the test case into JS Fiddle and also removed prefix (-webkit-) and then tested on Safari 15.5 on macOS 12.4, Firefox Nightly 103 and Chrome Canary 104, all browsers render same and show two lines.

Link - https://jsfiddle.net/vbyudg4t/

Not visible
ABC

Since all browsers are working same then I think this can be marked as "RESOLVED INVALID" or "RESOLVED CONFIGURATION CHANGED". If it is not expected behavior of spec, then it can be raised separately. Thanks!