Bug 12020 - REGRESSION: Flickr uploading broken
Summary: REGRESSION: Flickr uploading broken
Status: RESOLVED DUPLICATE of bug 12690
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.flickr.com
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-12-28 16:57 PST by Matt Lilek
Modified: 2007-03-02 00:29 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lilek 2006-12-28 16:57:15 PST
The Flickr upload screen appears and says to not close the window but then quickly goes back to the screen to chose what files to upload.

1. Sign into flickr.com
2. On the home page, click Upload photos
3. Chose a photo and click upload
4. The window changes to the standard flickr page letting you know its uploading and to not close the window, but then prints the following to the console on a debug build of r18457 and returns to the previous screen.

ERROR: connection:willCacheResponse: was called inside of [NSURLConnection initWithRequest:delegate:] (40676250)
(/Users/matt/Code/WebKit/WebCore/platform/network/mac/ResourceHandleMac.mm:312 -[WebCoreResourceHandleAsDelegate connection:willCacheResponse:])
ERROR: connection:willCacheResponse: was called inside of [NSURLConnection initWithRequest:delegate:] (40676250)
(/Users/matt/Code/WebKit/WebCore/platform/network/mac/ResourceHandleMac.mm:312 -[WebCoreResourceHandleAsDelegate connection:willCacheResponse:])
ERROR: connection:willCacheResponse: was called inside of [NSURLConnection initWithRequest:delegate:] (40676250)
(/Users/matt/Code/WebKit/WebCore/platform/network/mac/ResourceHandleMac.mm:312 -[WebCoreResourceHandleAsDelegate connection:willCacheResponse:])
[5323] http://flickr.com/ line 247: Error: SYNTAX_ERR: DOM Exception 12
[5323] http://flickr.com/photos/upload/ line 247: Error: SYNTAX_ERR: DOM Exception 12
[5323] http://flickr.com/photos/upload line 247: Error: SYNTAX_ERR: DOM Exception 12

The DOM exceptions it spews seem to be just for flavor as this happens in nightlies before we started reporting them (pre-r18320).
Comment 1 David Kilzer (:ddkilzer) 2007-01-16 03:22:59 PST
S60 port has a similar issue:  Bug 11169.

Comment 2 David Kilzer (:ddkilzer) 2007-01-16 03:25:28 PST
This may be fixed by Bug 12273.

Comment 3 Mark Rowe (bdash) 2007-01-16 19:26:37 PST
<rdar://problem/4928662>
Comment 4 Matt Lilek 2007-01-22 18:18:17 PST
(In reply to comment #2)
> This may be fixed by Bug 12273.

This was not fixed by the patch for bug 12273.
Comment 5 Antti Koivisto 2007-03-02 00:29:33 PST
This was broken by r18011

*** This bug has been marked as a duplicate of 12690 ***