Bug 120181 - regexp-match-reify-before-putbyval is not a JSRegress test
Summary: regexp-match-reify-before-putbyval is not a JSRegress test
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Michael Saboff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-22 16:45 PDT by Mark Hahnenberg
Modified: 2013-08-23 12:30 PDT (History)
2 users (show)

See Also:


Attachments
Patch (7.03 KB, patch)
2013-08-23 11:56 PDT, Michael Saboff
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hahnenberg 2013-08-22 16:45:25 PDT
It uses stuff that's not available when using run-jsc-benchmarks and it's not a performance test, which is what JSRegress is for (JS performance regression tests). Admittedly it's not well named, but I digress.
Comment 1 Michael Saboff 2013-08-23 11:56:24 PDT
Created attachment 209483 [details]
Patch
Comment 2 Mark Hahnenberg 2013-08-23 11:59:02 PDT
Comment on attachment 209483 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=209483&action=review

r=me

> LayoutTests/fast/js/regexp-match-reify-before-putbyval-expected.txt:4
> -JSRegress/regexp-match-reify-before-putbyval
> -
> -On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
> -
> -
>  PASS matches is ['http://www.dummy.com/images/123x456/image.jpg','http://www.dummy.com/images/',111,'x',222,'/image.jpg']
> -PASS no exception thrown
>  PASS successfullyParsed is true
>  
>  TEST COMPLETE

I'm confused...how are there two of the same file?
Comment 3 Geoffrey Garen 2013-08-23 11:59:07 PDT
Comment on attachment 209483 [details]
Patch

r=me
Comment 4 Mark Hahnenberg 2013-08-23 12:01:51 PDT
(In reply to comment #2)
> (From update of attachment 209483 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=209483&action=review
> 
> r=me
> 
> > LayoutTests/fast/js/regexp-match-reify-before-putbyval-expected.txt:4
> > -JSRegress/regexp-match-reify-before-putbyval
> > -
> > -On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
> > -
> > -
> >  PASS matches is ['http://www.dummy.com/images/123x456/image.jpg','http://www.dummy.com/images/',111,'x',222,'/image.jpg']
> > -PASS no exception thrown
> >  PASS successfullyParsed is true
> >  
> >  TEST COMPLETE
> 
> I'm confused...how are there two of the same file?

Ahh svn, you're a mystery wrapped in an enigma.
Comment 5 Michael Saboff 2013-08-23 12:02:49 PDT
(In reply to comment #2)
> (From update of attachment 209483 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=209483&action=review
> 
> r=me
> 
> > LayoutTests/fast/js/regexp-match-reify-before-putbyval-expected.txt:4
> > -JSRegress/regexp-match-reify-before-putbyval
> > -
> > -On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
> > -
> > -
> >  PASS matches is ['http://www.dummy.com/images/123x456/image.jpg','http://www.dummy.com/images/',111,'x',222,'/image.jpg']
> > -PASS no exception thrown
> >  PASS successfullyParsed is true
> >  
> >  TEST COMPLETE
> 
> I'm confused...how are there two of the same file?

Because there is a move then a change.
Comment 6 WebKit Commit Bot 2013-08-23 12:29:59 PDT
Comment on attachment 209483 [details]
Patch

Clearing flags on attachment: 209483

Committed r154506: <http://trac.webkit.org/changeset/154506>
Comment 7 WebKit Commit Bot 2013-08-23 12:30:01 PDT
All reviewed patches have been landed.  Closing bug.