Bug 120074 - In RenderTableCell::paintCollapsedBorders() check surrounding cells using physical rather than logical direction
Summary: In RenderTableCell::paintCollapsedBorders() check surrounding cells using phy...
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Robert Hogan
Depends on:
Blocks: 119759
  Show dependency treegraph
Reported: 2013-08-20 10:38 PDT by Robert Hogan
Modified: 2013-08-21 09:44 PDT (History)
5 users (show)

See Also:

Patch (5.92 KB, patch)
2013-08-20 10:47 PDT, Robert Hogan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Hogan 2013-08-20 10:38:28 PDT
cellAbove(), cellBelow() check the logical rather than the physical direction. This isn't what's needed in paintCollapsedBorders()
Comment 1 Robert Hogan 2013-08-20 10:47:28 PDT
Created attachment 209207 [details]
Comment 2 Dave Hyatt 2013-08-20 11:51:28 PDT
Comment on attachment 209207 [details]

This patch looks good, but it does highlight the fact that we need to rename cellBefore/After/Above/Below, since they aren't truly physical. I think we should rename them to:

previousCellInRow, nextCellInRow, cellInPreviousRow, cellInNextRow

I think that would be more clear than above/below/before/after, especially with how before/after is overloaded to mean "above/below" in writing modes. :)
Comment 3 WebKit Commit Bot 2013-08-21 09:43:58 PDT
Comment on attachment 209207 [details]

Clearing flags on attachment: 209207

Committed r154389: <http://trac.webkit.org/changeset/154389>
Comment 4 WebKit Commit Bot 2013-08-21 09:44:00 PDT
All reviewed patches have been landed.  Closing bug.