Bug 120040 - Save three bytes per CStringBuffer object
Summary: Save three bytes per CStringBuffer object
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Benjamin Poulain
URL:
Keywords: BlinkMergeCandidate
Depends on:
Blocks:
 
Reported: 2013-08-19 17:27 PDT by Ryosuke Niwa
Modified: 2013-08-24 21:38 PDT (History)
9 users (show)

See Also:


Attachments
Patch (3.02 KB, patch)
2013-08-23 13:45 PDT, Benjamin Poulain
darin: review+
gtk-ews: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2013-08-19 17:27:12 PDT
Merge https://chromium.googlesource.com/chromium/blink/+/894ae8eafdb64912aefd8f9c809f4ccda84f3b89

sizeof(CStringBuffer) was rounded up to 8 on account of struct size and
alignment rules. This is clearly not what was intended.

Also tidy up includes.
Comment 1 Benjamin Poulain 2013-08-23 13:45:48 PDT
Created attachment 209506 [details]
Patch
Comment 2 Darin Adler 2013-08-23 13:47:40 PDT
Comment on attachment 209506 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=209506&action=review

> Source/WTF/wtf/text/CString.h:49
> +    char* mutableData() { return reinterpret_cast<char*>(this + 1); }

Might need to use reinterpret_cast_ptr for the benefit of some ARM-based platforms.
Comment 3 kov's GTK+ EWS bot 2013-08-23 15:13:40 PDT
Comment on attachment 209506 [details]
Patch

Attachment 209506 [details] did not pass gtk-wk2-ews (gtk-wk2):
Output: http://webkit-queues.appspot.com/results/1543435
Comment 4 Benjamin Poulain 2013-08-24 21:38:24 PDT
Committed r154565: <http://trac.webkit.org/changeset/154565>