Bug 11982 - REGRESSION (r18159-r18187): Google Calendar does not load
: REGRESSION (r18159-r18187): Google Calendar does not load
Status: RESOLVED DUPLICATE of bug 11849
Product: WebKit
Classification: Unclassified
Component: HTML DOM
: 420+
: Macintosh Mac OS X 10.4
: P1 Major
Assigned To: Nobody
http://www.google.com/calendar/render...
: GoogleBug, HasReduction, Regression
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-26 11:10 PST by Bob Austin
Modified: 2006-12-26 12:44 PST (History)
2 users (show)

See Also:


Attachments
Reduced test case (68 bytes, text/html)
2006-12-26 12:44 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Austin 2006-12-26 11:10:02 PST
Google Calendar is no longer accessible as of WebKit build:
   WebKit-SVN-r18187.dmg

Steps: Sign in with any active gmail account
   http://www.google.com/calendar/render?pli=1
The Calendar does not draw.
Comment 1 Matt Lilek (pewtermoose) 2006-12-26 11:36:50 PST
For what its worth, this is spit out to the console when I load it:

http://www.google.com/calendar/20061214194148doozercompiled__en.js line 572: SyntaxError: Invalid regular expression: missing terminating ] for character class
http://www.google.com/calendar/render?pli=1 line 179: TypeError: Value undefined (result of expression _SR_genRegularTop) is not object.
http://www.google.com/calendar/render?pli=1 line 184: TypeError: Value undefined (result of expression _GenerateTopFrame) is not object.
http://www.google.com/calendar/render?pli=1 line 234: TypeError: Value undefined (result of expression _ResizeCalFrame) is not object.
Comment 2 David Kilzer (:ddkilzer) 2006-12-26 12:33:21 PST
(In reply to comment #1)
> For what its worth, this is spit out to the console when I load it:
> 
> http://www.google.com/calendar/20061214194148doozercompiled__en.js line 572:
> SyntaxError: Invalid regular expression: missing terminating ] for character
> class

Most likely related to r18182 (Bug 6257), which causes invalid regular expressions to throw errors.

Comment 3 Alexey Proskuryakov 2006-12-26 12:39:42 PST

*** This bug has been marked as a duplicate of 11849 ***
Comment 4 David Kilzer (:ddkilzer) 2006-12-26 12:44:11 PST
Created attachment 12043 [details]
Reduced test case

That was way too easy to find using Drosera.