Bug 11966 - REGRESSION: Divot removed from focus ring when typing and scrolling in textarea
Summary: REGRESSION: Divot removed from focus ring when typing and scrolling in textarea
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: data:text/html,%3Ctextarea%20rows=7%2...
Keywords: InRadar, Regression
Depends on: 11548
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-25 07:42 PST by David Kilzer (:ddkilzer)
Modified: 2007-12-07 11:32 PST (History)
1 user (show)

See Also:


Attachments
Screenshot of divot (3.18 KB, image/png)
2006-12-25 07:48 PST, David Kilzer (:ddkilzer)
no flags Details
Focus ring repaint test case (131 bytes, text/html)
2007-02-24 03:51 PST, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-12-25 07:42:22 PST
Summary:

A divot (chunk) of the focus ring is removed in the lower left-hand corner while typing and scrolling in a textarea.

Steps to reproduce:

1. Open data: URL in bug.
2. Focus textarea (click in it or tab into it).
3. Hit Enter key 8 times. [NOTE: Another bug ignores the first Enter key in a textarea on a newly loaded page.]
4. Type one printable character (even a space).
5. Hit Enter key once.
6. Type one printable character again.

Expected results:

No divot should be removed from textarea focus ring.

Actual results:

A divot is removed from the textarea focus ring.

Regression:

This does not occur in shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).  Tested on locally-built debug build of WebKit r18411.

Notes:

None.
Comment 1 David Kilzer (:ddkilzer) 2006-12-25 07:46:36 PST
NOTE: The divot may also appear farther to the right during word-wrap operations when typing at the bottom of a textarea with a scrollbar visible.  (I haven't quite figured out how to reproduce this reliably, but it happens when entering a new Bugzilla bug while typing the initial description.)
Comment 2 David Kilzer (:ddkilzer) 2006-12-25 07:48:37 PST
Created attachment 12018 [details]
Screenshot of divot
Comment 3 Mark Rowe (bdash) 2007-01-17 16:26:35 PST
<rdar://problem/4931387>
Comment 4 mitz 2007-02-24 03:51:35 PST
Created attachment 13360 [details]
Focus ring repaint test case

This is a bug in damage repair of focus rings. You can see it better if you scroll the square in this test case slowly into view. The root cause is probably WebCore's workaround for the CG quirk where focus rings aren't clipped.
Comment 5 mitz 2007-02-24 03:54:13 PST
Actually, in the test case in the URL, the bug can be reproduced even with a solid outline, because of bug 11548. If you change the textarea to be display: block, then the bug becomes exclusive to focus rings (outline-style: auto).
Comment 6 David Kilzer (:ddkilzer) 2007-05-15 16:40:09 PDT
I can't reproduce the original bug Comment #0 using a local debug build of WebKit r21489.  Mitz's test case still reproduces, though.

Comment 7 David Kilzer (:ddkilzer) 2007-06-03 07:21:55 PDT
(In reply to comment #6)
> I can't reproduce the original bug Comment #0 using a local debug build of
> WebKit r21489.  Mitz's test case still reproduces, though.

Just saw this again filling out the feedback form on this page:

http://developer.apple.com/contact/

Using a local debug build of WebKit r21908 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).

Comment 8 mitz 2007-12-07 11:32:02 PST
<http://trac.webkit.org/projects/webkit/changeset/28523> fixed the focus-ring specific issues. The rest of the problem is tracked by bug 11548.